Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(22)

Issue 596096: Refactoring various pieces of post interceptor caching. (Closed)

Created:
10 years, 10 months ago by antonm
Modified:
9 years, 4 months ago
CC:
v8-dev
Visibility:
Public.

Description

Refactoring various pieces of post interceptor caching. Committed: http://code.google.com/p/v8/source/detail?r=3857

Patch Set 1 #

Patch Set 2 : Fix incorrect indentation #

Total comments: 3
Unified diffs Side-by-side diffs Delta from patch set Stats (+138 lines, -126 lines) Patch
M src/arm/macro-assembler-arm.h View 2 chunks +7 lines, -0 lines 0 comments Download
M src/arm/macro-assembler-arm.cc View 2 chunks +25 lines, -0 lines 0 comments Download
M src/arm/stub-cache-arm.cc View 7 chunks +7 lines, -29 lines 0 comments Download
M src/ia32/macro-assembler-ia32.h View 2 chunks +6 lines, -0 lines 3 comments Download
M src/ia32/macro-assembler-ia32.cc View 2 chunks +24 lines, -0 lines 0 comments Download
M src/ia32/stub-cache-ia32.cc View 1 9 chunks +28 lines, -62 lines 0 comments Download
M src/x64/macro-assembler-x64.h View 2 chunks +7 lines, -0 lines 0 comments Download
M src/x64/macro-assembler-x64.cc View 2 chunks +25 lines, -0 lines 0 comments Download
M src/x64/stub-cache-x64.cc View 7 chunks +9 lines, -35 lines 0 comments Download

Messages

Total messages: 4 (0 generated)
antonm
Erik, may you have a look? It's just about moving pieces around.
10 years, 10 months ago (2010-02-12 19:56:14 UTC) #1
Vitaly Repeshko
LGTM. http://codereview.chromium.org/596096/diff/1001/1006 File src/ia32/macro-assembler-ia32.h (right): http://codereview.chromium.org/596096/diff/1001/1006#newcode127 src/ia32/macro-assembler-ia32.h:127: void InvokeFunction(JSFunction* function, I think this should either ...
10 years, 10 months ago (2010-02-12 20:32:40 UTC) #2
Mads Ager (chromium)
LGTM too. http://codereview.chromium.org/596096/diff/1001/1006 File src/ia32/macro-assembler-ia32.h (right): http://codereview.chromium.org/596096/diff/1001/1006#newcode127 src/ia32/macro-assembler-ia32.h:127: void InvokeFunction(JSFunction* function, On 2010/02/12 20:32:40, Vitaly ...
10 years, 10 months ago (2010-02-15 08:04:01 UTC) #3
antonm
10 years, 10 months ago (2010-02-15 08:54:26 UTC) #4
http://codereview.chromium.org/596096/diff/1001/1006
File src/ia32/macro-assembler-ia32.h (right):

http://codereview.chromium.org/596096/diff/1001/1006#newcode127
src/ia32/macro-assembler-ia32.h:127: void InvokeFunction(JSFunction* function,
On 2010/02/15 08:04:01, Mads Ager wrote:
> On 2010/02/12 20:32:40, Vitaly wrote:
> > I think this should either be named JumpFunction or take an InvokeFlag. Also
> > this needs a comment.
> 
> Agreed.  The usual naming is CallSomething and TailCallSomething.  If you pass
> in an InvokeFlag you can call it InvokeFunction.
> 
> 

Thanks a lot, Vitaly and Mads, flag added.  Submitting after William's change.

Powered by Google App Engine
This is Rietveld 408576698