Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(12)

Unified Diff: src/token.h

Issue 488017: Give the binary op stubs better names to make profiles more informative. (Closed) Base URL: http://v8.googlecode.com/svn/branches/bleeding_edge/
Patch Set: Created 11 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/ia32/codegen-ia32.cc ('k') | src/token.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/token.h
===================================================================
--- src/token.h (revision 3439)
+++ src/token.h (working copy)
@@ -211,14 +211,12 @@
};
#undef T
-#ifdef DEBUG
// Returns a string corresponding to the C++ token name
// (e.g. "LT" for the token LT).
static const char* Name(Value tok) {
ASSERT(0 <= tok && tok < NUM_TOKENS);
return name_[tok];
}
-#endif
// Predicates
static bool IsAssignmentOp(Value tok) {
@@ -261,9 +259,7 @@
}
private:
-#ifdef DEBUG
static const char* name_[NUM_TOKENS];
-#endif
static const char* string_[NUM_TOKENS];
static int8_t precedence_[NUM_TOKENS];
};
« no previous file with comments | « src/ia32/codegen-ia32.cc ('k') | src/token.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698