Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(279)

Issue 3573005: New attempt to make the allocation routines 64 bit clean.... (Closed)

Created:
10 years, 2 months ago by Erik Corry
Modified:
9 years, 7 months ago
CC:
v8-dev
Visibility:
Public.

Description

New attempt to make the allocation routines 64 bit clean. This one has been approved by the 64 bit compiler in MSVC 2005 so I hope it also passes the 2008 version. The --max-new-space-size option is now in kBytes. The --max-old-space-size option is now in MBytes. Some issues remain with 64 bit heaps and the counters. See http://code.google.com/p/v8/issues/detail?id=887 Committed: http://code.google.com/p/v8/source/detail?r=5559

Patch Set 1 #

Total comments: 8
Unified diffs Side-by-side diffs Delta from patch set Stats (+322 lines, -232 lines) Patch
M src/api.cc View 2 chunks +13 lines, -13 lines 0 comments Download
M src/arm/simulator-arm.cc View 5 chunks +7 lines, -5 lines 0 comments Download
M src/assembler.cc View 2 chunks +2 lines, -2 lines 0 comments Download
M src/contexts.cc View 2 chunks +3 lines, -2 lines 0 comments Download
M src/data-flow.cc View 1 chunk +1 line, -1 line 0 comments Download
M src/disassembler.cc View 1 chunk +4 lines, -1 line 0 comments Download
M src/flag-definitions.h View 1 chunk +2 lines, -2 lines 0 comments Download
M src/global-handles.cc View 2 chunks +5 lines, -3 lines 0 comments Download
M src/heap.h View 9 chunks +34 lines, -34 lines 0 comments Download
M src/heap.cc View 20 chunks +67 lines, -47 lines 4 comments Download
M src/heap-inl.h View 1 chunk +1 line, -1 line 0 comments Download
M src/log.h View 3 chunks +3 lines, -1 line 0 comments Download
M src/log.cc View 3 chunks +20 lines, -2 lines 0 comments Download
M src/mark-compact.cc View 3 chunks +8 lines, -6 lines 0 comments Download
M src/objects-debug.cc View 4 chunks +8 lines, -8 lines 0 comments Download
M src/parser.h View 2 chunks +4 lines, -3 lines 0 comments Download
M src/regexp-macro-assembler-tracer.cc View 16 chunks +34 lines, -23 lines 2 comments Download
M src/runtime.cc View 1 chunk +1 line, -1 line 0 comments Download
M src/spaces.h View 22 chunks +52 lines, -44 lines 2 comments Download
M src/spaces.cc View 12 chunks +27 lines, -17 lines 0 comments Download
M src/utils.h View 1 chunk +15 lines, -5 lines 0 comments Download
M test/cctest/test-alloc.cc View 1 chunk +1 line, -1 line 0 comments Download
M test/cctest/test-api.cc View 2 chunks +4 lines, -4 lines 0 comments Download
M test/cctest/test-log-stack-tracer.cc View 1 chunk +2 lines, -2 lines 0 comments Download
M test/cctest/test-spaces.cc View 1 chunk +1 line, -1 line 0 comments Download
M test/mjsunit/binary-op-newspace.js View 1 chunk +1 line, -1 line 0 comments Download
M test/mjsunit/math-abs.js View 1 chunk +1 line, -1 line 0 comments Download
M test/mjsunit/math-floor.js View 1 chunk +1 line, -1 line 0 comments Download

Messages

Total messages: 3 (0 generated)
Erik Corry
10 years, 2 months ago (2010-09-29 14:44:54 UTC) #1
Vyacheslav Egorov (Chromium)
LGTM http://codereview.chromium.org/3573005/diff/1/11 File src/heap.cc (right): http://codereview.chromium.org/3573005/diff/1/11#newcode706 src/heap.cc:706: int start_new_space_size = static_cast<int>(Heap::new_space()->IntSize()); seems wrong. http://codereview.chromium.org/3573005/diff/1/11#newcode4095 src/heap.cc:4095: ...
10 years, 2 months ago (2010-09-29 14:55:19 UTC) #2
Erik Corry
10 years, 2 months ago (2010-09-30 07:09:38 UTC) #3
http://codereview.chromium.org/3573005/diff/1/11
File src/heap.cc (right):

http://codereview.chromium.org/3573005/diff/1/11#newcode706
src/heap.cc:706: int start_new_space_size =
static_cast<int>(Heap::new_space()->IntSize());
On 2010/09/29 14:55:20, Vyacheslav Egorov wrote:
> seems wrong.

Done.

http://codereview.chromium.org/3573005/diff/1/11#newcode4095
src/heap.cc:4095: *stats->new_space_size = new_space_.IntSize();
On 2010/09/29 14:55:20, Vyacheslav Egorov wrote:
> Better call this method SizeAsInt

Done.

http://codereview.chromium.org/3573005/diff/1/18
File src/regexp-macro-assembler-tracer.cc (right):

http://codereview.chromium.org/3573005/diff/1/18#newcode58
src/regexp-macro-assembler-tracer.cc:58: PrintF("label[%08x]: (Bind)\n",
IntForLabel(label));
On 2010/09/29 14:55:20, Vyacheslav Egorov wrote:
> consider renaming it to LabelToInt. 

Done.

http://codereview.chromium.org/3573005/diff/1/21
File src/spaces.h (right):

http://codereview.chromium.org/3573005/diff/1/21#newcode1482
src/spaces.h:1482: int IntSize() { return static_cast<int>(Size()); }
On 2010/09/29 14:55:20, Vyacheslav Egorov wrote:
> SizeAsInt ?

Done.

Powered by Google App Engine
This is Rietveld 408576698