Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(213)

Unified Diff: webkit/glue/plugins/pepper_buffer.h

Issue 3255003: Pull new PPAPI, rename non-P0 interfaces to Dev, rename DeviceContext2D to Gr... (Closed) Base URL: svn://chrome-svn/chrome/trunk/src/
Patch Set: Created 10 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « remoting/client/plugin/pepper_view.cc ('k') | webkit/glue/plugins/pepper_buffer.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: webkit/glue/plugins/pepper_buffer.h
===================================================================
--- webkit/glue/plugins/pepper_buffer.h (revision 57791)
+++ webkit/glue/plugins/pepper_buffer.h (working copy)
@@ -7,9 +7,10 @@
#include "base/basictypes.h"
#include "base/scoped_ptr.h"
-#include "third_party/ppapi/c/ppb_buffer.h"
#include "webkit/glue/plugins/pepper_resource.h"
+struct PPB_Buffer_Dev;
+
namespace pepper {
class PluginInstance;
@@ -28,7 +29,7 @@
// Returns a pointer to the interface implementing PPB_Buffer that is
// exposed to the plugin.
- static const PPB_Buffer* GetInterface();
+ static const PPB_Buffer_Dev* GetInterface();
// Resource overrides.
Buffer* AsBuffer() { return this; }
« no previous file with comments | « remoting/client/plugin/pepper_view.cc ('k') | webkit/glue/plugins/pepper_buffer.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698