Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(828)

Unified Diff: webkit/glue/plugins/pepper_widget.h

Issue 3255003: Pull new PPAPI, rename non-P0 interfaces to Dev, rename DeviceContext2D to Gr... (Closed) Base URL: svn://chrome-svn/chrome/trunk/src/
Patch Set: Created 10 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « webkit/glue/plugins/pepper_var.h ('k') | webkit/glue/plugins/pepper_widget.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: webkit/glue/plugins/pepper_widget.h
===================================================================
--- webkit/glue/plugins/pepper_widget.h (revision 57791)
+++ webkit/glue/plugins/pepper_widget.h (working copy)
@@ -9,8 +9,8 @@
#include "third_party/ppapi/c/pp_rect.h"
#include "webkit/glue/plugins/pepper_resource.h"
-typedef struct _ppb_Widget PPB_Widget;
-typedef struct _pp_Event PP_Event;
+struct PPB_Widget_Dev;
+struct PP_Event;
namespace pepper {
@@ -24,7 +24,7 @@
// Returns a pointer to the interface implementing PPB_Widget that is
// exposed to the plugin.
- static const PPB_Widget* GetInterface();
+ static const PPB_Widget_Dev* GetInterface();
// Resource overrides.
Widget* AsWidget() { return this; }
« no previous file with comments | « webkit/glue/plugins/pepper_var.h ('k') | webkit/glue/plugins/pepper_widget.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698