Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(284)

Unified Diff: webkit/glue/plugins/pepper_url_util.h

Issue 3255003: Pull new PPAPI, rename non-P0 interfaces to Dev, rename DeviceContext2D to Gr... (Closed) Base URL: svn://chrome-svn/chrome/trunk/src/
Patch Set: Created 10 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « webkit/glue/plugins/pepper_url_response_info.cc ('k') | webkit/glue/plugins/pepper_url_util.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: webkit/glue/plugins/pepper_url_util.h
===================================================================
--- webkit/glue/plugins/pepper_url_util.h (revision 57791)
+++ webkit/glue/plugins/pepper_url_util.h (working copy)
@@ -5,11 +5,14 @@
#ifndef WEBKIT_GLUE_PLUGINS_PEPPER_URL_UTIL_H_
#define WEBKIT_GLUE_PLUGINS_PEPPER_URL_UTIL_H_
-typedef struct _ppb_UrlUtil PPB_UrlUtil;
+struct PPB_UrlUtil_Dev;
namespace pepper {
-const PPB_UrlUtil* GetUrlUtilInterface();
+class UrlUtil {
+ public:
+ static const PPB_UrlUtil_Dev* GetInterface();
+};
} // namespace pepper
« no previous file with comments | « webkit/glue/plugins/pepper_url_response_info.cc ('k') | webkit/glue/plugins/pepper_url_util.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698