Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(136)

Issue 3135022: Give correct value ranges to enumeration types used as opaque types. (Closed)

Created:
10 years, 4 months ago by Vyacheslav Egorov (Chromium)
Modified:
9 years, 7 months ago
CC:
v8-dev, tfarina
Visibility:
Public.

Description

Give correct value ranges to enumeration types used as opaque types. This allows to remove special handling of GCC 4.4 (disabling of Value Range Propagation) from SConstruct. BUG=http://code.google.com/p/v8/issues/detail?id=830 Committed: http://code.google.com/p/v8/source/detail?r=5278

Patch Set 1 #

Total comments: 4

Patch Set 2 : fixed #

Unified diffs Side-by-side diffs Delta from patch set Stats (+22 lines, -12 lines) Patch
M SConstruct View 1 chunk +2 lines, -9 lines 0 comments Download
M src/frames.h View 1 1 chunk +7 lines, -1 line 0 comments Download
M src/objects.h View 1 1 chunk +6 lines, -1 line 0 comments Download
M src/platform.h View 1 1 chunk +7 lines, -1 line 0 comments Download

Messages

Total messages: 3 (0 generated)
Vyacheslav Egorov (Chromium)
10 years, 4 months ago (2010-08-16 14:12:34 UTC) #1
Mads Ager (chromium)
LGTM http://codereview.chromium.org/3135022/diff/1/3 File src/frames.h (right): http://codereview.chromium.org/3135022/diff/1/3#newcode117 src/frames.h:117: enum Id { kIdMinValue = kMinInt, kIdMaxValue = ...
10 years, 4 months ago (2010-08-16 16:32:30 UTC) #2
tfarina
10 years, 4 months ago (2010-08-16 18:06:44 UTC) #3
http://codereview.chromium.org/3135022/diff/1/3
File src/frames.h (right):

http://codereview.chromium.org/3135022/diff/1/3#newcode117
src/frames.h:117: enum Id { kIdMinValue = kMinInt, kIdMaxValue = kMaxInt, NO_ID
= 0 };
On 2010/08/16 16:32:30, Mads Ager wrote:
> There is a mix of camel case and all caps here. Could you check what the style
> guide says and make it consistent?
There is a divergence in google/chromium style. Not sure what v8 is using
though.

The chromium coding style says:
"Though the style guide says to use kConstantNaming for enums now, we still use
MACRO_STYLE naming for enums for consistency with existing code."
http://www.chromium.org/developers/coding-style

But Google C++ style says:
Enumerators should be named either like constants or like macros: either
kEnumName or ENUM_NAME.

http://google-styleguide.googlecode.com/svn/trunk/cppguide.xml?showone=Enumer...

Powered by Google App Engine
This is Rietveld 408576698