Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(200)

Unified Diff: webkit/glue/plugins/plugin_list_win.cc

Issue 293013: Deprecate PathService::Get(..., wstring*) and use FilePath instead. (Closed)
Patch Set: Created 11 years, 2 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« chrome/test/ui/ui_test.cc ('K') | « chrome/test/ui/ui_test.cc ('k') | no next file » | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: webkit/glue/plugins/plugin_list_win.cc
diff --git a/webkit/glue/plugins/plugin_list_win.cc b/webkit/glue/plugins/plugin_list_win.cc
index 95762381c5b33cdc206395da90b70172a8212edf..7506ed03adae5f75ecfad4eb0e2843453371ff87 100644
--- a/webkit/glue/plugins/plugin_list_win.cc
+++ b/webkit/glue/plugins/plugin_list_win.cc
@@ -121,10 +121,11 @@ void GetFirefoxDirectory(std::set<FilePath>* plugin_dirs) {
GetPluginsInRegistryDirectory(
HKEY_LOCAL_MACHINE, kRegistryMozillaPlugins, plugin_dirs);
- std::wstring firefox_app_data_plugin_path;
+ FilePath firefox_app_data_plugin_path;
if (PathService::Get(base::DIR_APP_DATA, &firefox_app_data_plugin_path)) {
- firefox_app_data_plugin_path += L"\\Mozilla\\plugins";
- plugin_dirs->insert(FilePath(firefox_app_data_plugin_path));
+ firefox_app_data_plugin_path =
+ firefox_app_data_plugin_path.AppendASCII("Mozilla/plugins");
tony 2009/10/19 22:46:49 Is it safe to embed the '/' here or do you need to
Evan Stade 2009/10/19 22:54:31 <bikeshedding> I agree AppendASCII twice is proba
+ plugin_dirs->insert(firefox_app_data_plugin_path);
}
}
« chrome/test/ui/ui_test.cc ('K') | « chrome/test/ui/ui_test.cc ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698