Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(919)

Unified Diff: update_attempter.h

Issue 2819059: Narrow down to one generic error per action. (Closed) Base URL: ssh://git@gitrw.chromium.org:9222/update_engine.git
Patch Set: Rename SwitchToActionSpecificCode to GetErrorCodeForAction. Created 10 years, 5 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « action_processor.h ('k') | update_attempter.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: update_attempter.h
diff --git a/update_attempter.h b/update_attempter.h
index e84c4798c7caea34410beb4ed34ec86d15ea8f62..269edec3c8d93f425e2ac7450bb42280bf445b6a 100644
--- a/update_attempter.h
+++ b/update_attempter.h
@@ -90,7 +90,7 @@ class UpdateAttempter : public ActionProcessorDelegate,
// Creates an error event object in |error_event_| to be included in
// an OmahaRequestAction once the current action processor is done.
- void CreatePendingErrorEvent(ActionExitCode code);
+ void CreatePendingErrorEvent(AbstractAction* action, ActionExitCode code);
// If there's a pending error event allocated in |error_event_|,
// schedules an OmahaRequestAction with that event in the current
« no previous file with comments | « action_processor.h ('k') | update_attempter.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698