Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(200)

Issue 27269: Align code entry points to 32 bytes. (Closed)

Created:
11 years, 10 months ago by iposva
Modified:
9 years, 3 months ago
Reviewers:
Kasper Lund
CC:
v8-dev
Visibility:
Public.

Description

Align code entry points to 32 bytes. Committed: http://code.google.com/p/v8/source/detail?r=1386

Patch Set 1 #

Total comments: 6
Unified diffs Side-by-side diffs Delta from patch set Stats (+10 lines, -4 lines) Patch
M src/heap.cc View 1 chunk +1 line, -0 lines 4 comments Download
M src/objects.h View 2 chunks +7 lines, -2 lines 2 comments Download
M src/objects-inl.h View 2 chunks +2 lines, -2 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
iposva
11 years, 10 months ago (2009-02-27 10:22:40 UTC) #1
Kasper Lund
LGTM. http://codereview.chromium.org/27269/diff/1/2 File src/heap.cc (right): http://codereview.chromium.org/27269/diff/1/2#newcode1634 Line 1634: ASSERT((obj_size % Code::kCodeAlignment) == 0); IsAligned(obj_size, Code::kCodeAlignment) ...
11 years, 10 months ago (2009-02-27 10:32:11 UTC) #2
iposva
11 years, 10 months ago (2009-02-27 11:08:28 UTC) #3
http://codereview.chromium.org/27269/diff/1/2
File src/heap.cc (right):

http://codereview.chromium.org/27269/diff/1/2#newcode1634
Line 1634: ASSERT((obj_size % Code::kCodeAlignment) == 0);
On 2009/02/27 10:32:11, Kasper Lund wrote:
> IsAligned(obj_size, Code::kCodeAlignment) would be easier to read.

Done.

http://codereview.chromium.org/27269/diff/1/2#newcode1669
Line 1669: return code;
On 2009/02/27 10:32:11, Kasper Lund wrote:
> It would be nice if you could assert that the entry point (instruction start)
is
> aligned the way you want it.

Done now as part of CodeVerify().

http://codereview.chromium.org/27269/diff/1/3
File src/objects.h (right):

http://codereview.chromium.org/27269/diff/1/3#newcode2282
Line 2282: static const int kFiller6Offset = kKindSpecificFlagsOffset +
kIntSize;
On 2009/02/27 10:32:11, Kasper Lund wrote:
> Comment on why you need fillers here?

Done.

Powered by Google App Engine
This is Rietveld 408576698