Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(3)

Issue 21370: Implement deferToInterceptor function to help with readability of the binding... (Closed)

Created:
11 years, 10 months ago by dglazkov
Modified:
7 years, 5 months ago
Reviewers:
macdome, Mads Ager (chromium), eseidel
CC:
chromium-reviews_googlegroups.com
Visibility:
Public.

Description

Implement deferToInterceptor function to help with readability of the bindings code. R=eseidel

Patch Set 1 #

Total comments: 1
Unified diffs Side-by-side diffs Delta from patch set Stats (+11 lines, -4 lines) Patch
M third_party/WebKit/WebCore/bindings/v8/V8Proxy.h View 1 chunk +7 lines, -0 lines 1 comment Download
M third_party/WebKit/WebCore/bindings/v8/custom/V8HTMLPlugInElementCustom.cpp View 2 chunks +4 lines, -4 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
dglazkov
11 years, 10 months ago (2009-02-13 23:57:28 UTC) #1
macdome_gmail.com
LGTM.
11 years, 10 months ago (2009-02-14 00:36:12 UTC) #2
Mads Ager (chromium)
11 years, 10 months ago (2009-02-16 06:46:10 UTC) #3
LGTM, good idea to make the intention clear here.

http://codereview.chromium.org/21370/diff/1/2
File third_party/WebKit/WebCore/bindings/v8/V8Proxy.h (right):

http://codereview.chromium.org/21370/diff/1/2#newcode42
Line 42: inline static v8::Local<v8::Object> deferToInterceptor()
We should name this differently.  The NamedPropertyGetter/Setter and
IndexedPropertyGetter/Setter *are* the interceptors.  Returning an empty handle
from an interceptor signal to V8 that it should continue normal JavaScript
lookup on the actual JavaScript wrapper objects.  Call it something like
continueLookup?

Powered by Google App Engine
This is Rietveld 408576698