Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1372)

Issue 207014: Various cleanups FTP-related. (Closed)

Created:
11 years, 3 months ago by Paweł Hajdan Jr.
Modified:
9 years, 7 months ago
Reviewers:
eroman, wtc
CC:
chromium-reviews_googlegroups.com
Visibility:
Public.

Description

Various cleanups FTP-related. - use better name for FTP LIST parsing code in about:credits - don't open a second data socket - add a comment explaining why we close the data socket at one point TEST=Covered by net_unittests. BUG=none Committed: http://src.chromium.org/viewvc/chrome?view=rev&revision=26575

Patch Set 1 #

Total comments: 2
Unified diffs Side-by-side diffs Delta from patch set Stats (+24 lines, -42 lines) Patch
M chrome/browser/resources/about_credits.html View 1 chunk +4 lines, -4 lines 1 comment Download
M net/ftp/ftp_network_transaction.cc View 2 chunks +6 lines, -2 lines 0 comments Download
M net/ftp/ftp_network_transaction_unittest.cc View 7 chunks +5 lines, -26 lines 0 comments Download
M net/url_request/url_request_new_ftp_job.h View 1 chunk +1 line, -1 line 0 comments Download
M net/url_request/url_request_new_ftp_job.cc View 2 chunks +8 lines, -9 lines 1 comment Download

Messages

Total messages: 4 (0 generated)
Paweł Hajdan Jr.
I collected the comments left after I committed several of my FTP patches, and made ...
11 years, 3 months ago (2009-09-17 16:30:33 UTC) #1
eroman
lgtm
11 years, 3 months ago (2009-09-18 01:50:11 UTC) #2
wtc
LGTM! http://codereview.chromium.org/207014/diff/1/2 File chrome/browser/resources/about_credits.html (right): http://codereview.chromium.org/207014/diff/1/2#newcode1330 Line 1330: <span class="homepage"><a href="http://mxr.mozilla.org/mozilla-central/source/netwerk/streamconv/converters/ParseFTPList.cpp">homepage</a></span> Daniel Berlin wanted us ...
11 years, 3 months ago (2009-09-18 17:24:39 UTC) #3
Paweł Hajdan Jr.
11 years, 3 months ago (2009-09-18 17:31:08 UTC) #4
On Fri, Sep 18, 2009 at 10:24, <wtc@chromium.org> wrote:

> http://codereview.chromium.org/207014/diff/1/2
> File chrome/browser/resources/about_credits.html (right):
>
> http://codereview.chromium.org/207014/diff/1/2#newcode1330
> Line 1330: <span class="homepage"><a
> href="
>
http://mxr.mozilla.org/mozilla-central/source/netwerk/streamconv/converters/P...
> ">homepage</a></span>
> Daniel Berlin wanted us to point to the revision of the file
> that we derived from.  I haven't figured out the right away
> to do that in Mozilla's MXR browser.  This is probably OK.
>
>
http://hg.mozilla.org/mozilla-central/file/179c6f22d6f2/netwerk/streamconv/co...


Hmm... this is going to be a maintainability problem. I generally want to
stay on Mozilla's trunk, and in the long term rewrite the code. Mozilla's
VMS parsing code is not even correct, so we don't get any advantage for
"oddball" servers by using it. I was recently rewriting some other piece of
Mozilla code, and it became shorter, and better tested. It was also fun!


> http://codereview.chromium.org/207014/diff/1/5
> File net/url_request/url_request_new_ftp_job.cc (right):
>
> http://codereview.chromium.org/207014/diff/1/5#newcode319
> Line 319: void URLRequestNewFtpJob::LogFtpServerType(char server_type) {
> Nit: may want to name the parameter "list_style" and declare
> it as 'int' because state.lstyle is an 'int'.  (It's
> conventional in C code to use the 'int' type for
> function parameters that are 'char'.  I don't know why.)


In Chromium code I'd prefer more explicit type. Well, it is a char. Even old
C++ code sometimes uses int for bools... If it's not a strong nit, I'd
rather leave it as-is.

Powered by Google App Engine
This is Rietveld 408576698