Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(257)

Issue 1700005: Fix bugs introduced by r4475:... (Closed)

Created:
10 years, 8 months ago by Vyacheslav Egorov (Chromium)
Modified:
9 years, 7 months ago
CC:
v8-dev
Visibility:
Public.

Description

Fix bugs introduced by r4475: - RelinkPageListInChunkOrder might relink unused pages into the middle of a sequence of used pages. Filler objects should be placed at the beginning of such unused pages otherwise generic iterators (e.g. HeapObjectIterator) would not handle them correctly. - ObjectAreaEnd() should not be used as an allocation limit for pages from FixedSpace. Pages in such spaces do not use top page_extra_ bytes of object area. TBR=ager@chromium.org Committed: http://code.google.com/p/v8/source/detail?r=4476

Patch Set 1 : '' #

Total comments: 1
Unified diffs Side-by-side diffs Delta from patch set Stats (+51 lines, -39 lines) Patch
M src/mark-compact.cc View 2 chunks +12 lines, -18 lines 1 comment Download
M src/spaces.h View 4 chunks +16 lines, -10 lines 0 comments Download
M src/spaces.cc View 5 chunks +22 lines, -10 lines 0 comments Download
M test/cctest/test-heap.cc View 1 chunk +1 line, -1 line 0 comments Download

Messages

Total messages: 2 (0 generated)
Vyacheslav Egorov (Chromium)
10 years, 8 months ago (2010-04-22 16:42:23 UTC) #1
Mads Ager (chromium)
10 years, 8 months ago (2010-04-23 06:48:37 UTC) #2
LGTM

http://codereview.chromium.org/1700005/diff/6001/7004
File src/mark-compact.cc (right):

http://codereview.chromium.org/1700005/diff/6001/7004#newcode1396
src/mark-compact.cc:1396: ASSERT(((first_empty_page == NULL) &&
Now that you have an #ifdef DEBUG here in any case it would be more readable
with ifs and multiple ASSERTS. :)

Another small comment: Kevin made me aware that Page has an is_valid() method
that can be used instead of explicit checking Page pointers against NULL. Also,
it seems that in most other code, we use Page::FromAddress(NULL) instead of
using NULL explicitly in initializations.

Powered by Google App Engine
This is Rietveld 408576698