Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(23)

Issue 122030: X64: Implemented InvokeFunction (Closed)

Created:
11 years, 6 months ago by Lasse Reichstein
Modified:
9 years, 6 months ago
Reviewers:
William Hesse
CC:
v8-dev
Visibility:
Public.

Description

X64: Implemented InvokeFunction

Patch Set 1 #

Total comments: 4
Unified diffs Side-by-side diffs Delta from patch set Stats (+316 lines, -14 lines) Patch
M src/assembler.cc View 1 chunk +1 line, -1 line 0 comments Download
M src/x64/assembler-x64.h View 1 chunk +0 lines, -1 line 0 comments Download
M src/x64/assembler-x64.cc View 2 chunks +2 lines, -2 lines 0 comments Download
M src/x64/builtins-x64.cc View 3 chunks +118 lines, -2 lines 1 comment Download
M src/x64/macro-assembler-x64.h View 2 chunks +3 lines, -3 lines 0 comments Download
M src/x64/macro-assembler-x64.cc View 3 chunks +192 lines, -5 lines 3 comments Download

Messages

Total messages: 2 (0 generated)
Lasse Reichstein
Review, please.
11 years, 6 months ago (2009-06-11 09:15:48 UTC) #1
William Hesse
11 years, 6 months ago (2009-06-11 09:32:29 UTC) #2
LGTM

http://codereview.chromium.org/122030/diff/1/5
File src/x64/builtins-x64.cc (right):

http://codereview.chromium.org/122030/diff/1/5#newcode70
Line 70: // rbx holds a Smi.
holds a Smi.  Therefore, we convert to a dword offset by multiplying by 4.

http://codereview.chromium.org/122030/diff/1/6
File src/x64/macro-assembler-x64.cc (right):

http://codereview.chromium.org/122030/diff/1/6#newcode45
Line 45: }
These are already implemented (using incl and addl).  Update your checkout.

http://codereview.chromium.org/122030/diff/1/6#newcode340
Line 340: const int sentinel = SharedFunctionInfo::kDontAdaptArgumentsSentinel;
This is only used once.  It is no more constant than its RHS is.  I don't think
this constant is worth the trouble of defining.

http://codereview.chromium.org/122030/diff/1/6#newcode432
Line 432: ASSERT(fun.is(rdi));
Can we use function instead of fun as the parameter name?  We should stick
closer to the standard of always using complete words.

Powered by Google App Engine
This is Rietveld 408576698