Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(108)

Issue 113763: Merge in changes from readability review. (Closed)

Created:
11 years, 7 months ago by Mikhail Naganov
Modified:
9 years, 7 months ago
CC:
v8-dev
Visibility:
Public.

Description

Merge in changes from readability review. All changes from http://codereview.chromium.org/115024, except splitting namespace declarations in two lines (will be done separately for all source files). Committed: http://code.google.com/p/v8/source/detail?r=2037

Patch Set 1 #

Total comments: 4
Unified diffs Side-by-side diffs Delta from patch set Stats (+78 lines, -55 lines) Patch
M src/codegen.cc View 1 chunk +1 line, -1 line 0 comments Download
M src/compiler.cc View 2 chunks +2 lines, -2 lines 0 comments Download
M src/func-name-inferrer.h View 3 chunks +22 lines, -10 lines 0 comments Download
M src/log.h View 2 chunks +2 lines, -2 lines 0 comments Download
M src/log.cc View 7 chunks +41 lines, -33 lines 2 comments Download
M test/cctest/test-func-name-inference.cc View 2 chunks +10 lines, -7 lines 2 comments Download

Messages

Total messages: 3 (0 generated)
Mikhail Naganov
11 years, 7 months ago (2009-05-22 12:00:57 UTC) #1
Søren Thygesen Gjesse
LGTM Congratulations on you C++ readability! http://codereview.chromium.org/113763/diff/1/5 File src/log.cc (right): http://codereview.chromium.org/113763/diff/1/5#newcode308 Line 308: static bool ...
11 years, 7 months ago (2009-05-25 06:38:31 UTC) #2
Mikhail Naganov
11 years, 7 months ago (2009-05-25 08:38:51 UTC) #3
http://codereview.chromium.org/113763/diff/1/5
File src/log.cc (right):

http://codereview.chromium.org/113763/diff/1/5#newcode308
Line 308: static bool is_enabled() {
On 2009/05/25 06:38:31, Søren Gjesse wrote:
> How about changing this to IsEnabled() as well? This is no really an accessor.

Good idea. Done.

http://codereview.chromium.org/113763/diff/1/7
File test/cctest/test-func-name-inference.cc (right):

http://codereview.chromium.org/113763/diff/1/7#newcode35
Line 35: using ::v8::internal::CStrVector;
On 2009/05/25 06:38:31, Søren Gjesse wrote:
> I must admit that I would prefer to not use "using" and either use a namespace
> alias or use full namespaces, but lets keep it with "using" for now and
getting
> rid of the  mix of "using" and namespace alias is good.

Honestly, me too, because when using "using" it's good to have some auto-checker
that helps to get rid of no more used imports (like the tool that track imports
for Java).

Powered by Google App Engine
This is Rietveld 408576698