Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(191)

Issue 113622: Expose the calling context through the API. ... (Closed)

Created:
11 years, 7 months ago by Mads Ager (chromium)
Modified:
9 years, 7 months ago
Reviewers:
Kasper Lund
CC:
v8-dev
Visibility:
Public.

Description

Expose the calling context through the API. In C++ callbacks, we can now get the context of the javascript code that called the callback. Committed: http://code.google.com/p/v8/source/detail?r=2006

Patch Set 1 #

Total comments: 2

Patch Set 2 : '' #

Unified diffs Side-by-side diffs Delta from patch set Stats (+92 lines, -0 lines) Patch
M include/v8.h View 1 chunk +7 lines, -0 lines 0 comments Download
M src/api.cc View 1 1 chunk +7 lines, -0 lines 0 comments Download
M src/top.h View 1 1 chunk +5 lines, -0 lines 0 comments Download
M src/top.cc View 1 1 chunk +9 lines, -0 lines 0 comments Download
M test/cctest/test-api.cc View 1 chunk +64 lines, -0 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
Mads Ager (chromium)
11 years, 7 months ago (2009-05-20 07:12:46 UTC) #1
Kasper Lund
LGTM. http://codereview.chromium.org/113622/diff/1/6 File src/top.h (right): http://codereview.chromium.org/113622/diff/1/6#newcode263 Line 263: static Handle<Context> calling_global_context(); I'd like to rename ...
11 years, 7 months ago (2009-05-20 07:22:15 UTC) #2
Mads Ager (chromium)
11 years, 7 months ago (2009-05-20 07:42:03 UTC) #3
http://codereview.chromium.org/113622/diff/1/6
File src/top.h (right):

http://codereview.chromium.org/113622/diff/1/6#newcode263
Line 263: static Handle<Context> calling_global_context();
On 2009/05/20 07:22:15, Kasper Lund wrote:
> I'd like to rename this to GetCallingGlobalContext or something. It's weird
that
> it uses the accessor naming convention. We should consider changing some of
the
> other methods in Top too, but you don't have to do that now.

Done for this one and I agree that we should clean up the rest as well.  Thanks!

Powered by Google App Engine
This is Rietveld 408576698