Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(5)

Issue 8888002: Fix displaying generic types. (Closed)

Created:
9 years ago by Bob Nystrom
Modified:
9 years ago
Reviewers:
Jennifer Messerly
CC:
reviews_dartlang.org
Visibility:
Public.

Description

Fix displaying generic types. Committed: https://code.google.com/p/dart/source/detail?r=2219

Patch Set 1 #

Total comments: 1

Patch Set 2 : Respond to review. #

Unified diffs Side-by-side diffs Delta from patch set Stats (+2 lines, -1 line) Patch
M utils/dartdoc/dartdoc.dart View 1 1 chunk +2 lines, -1 line 0 comments Download

Messages

Total messages: 4 (0 generated)
Bob Nystrom
9 years ago (2011-12-08 02:15:31 UTC) #1
Jennifer Messerly
http://codereview.chromium.org/8888002/diff/1/utils/dartdoc/dartdoc.dart File utils/dartdoc/dartdoc.dart (right): http://codereview.chromium.org/8888002/diff/1/utils/dartdoc/dartdoc.dart#newcode633 utils/dartdoc/dartdoc.dart:633: write(a(typeUrl(type), type.genericType.name)); I'd just use: write(a(typeUrl(type), type.genericType.name)); and both ...
9 years ago (2011-12-08 02:19:12 UTC) #2
Bob Nystrom
On 2011/12/08 02:19:12, John Messerly wrote: > http://codereview.chromium.org/8888002/diff/1/utils/dartdoc/dartdoc.dart > File utils/dartdoc/dartdoc.dart (right): > > http://codereview.chromium.org/8888002/diff/1/utils/dartdoc/dartdoc.dart#newcode633 ...
9 years ago (2011-12-08 02:21:59 UTC) #3
Jennifer Messerly
9 years ago (2011-12-08 02:23:00 UTC) #4
On 2011/12/08 02:21:59, Bob Nystrom wrote:
> On 2011/12/08 02:19:12, John Messerly wrote:
> > http://codereview.chromium.org/8888002/diff/1/utils/dartdoc/dartdoc.dart
> > File utils/dartdoc/dartdoc.dart (right):
> > 
> >
>
http://codereview.chromium.org/8888002/diff/1/utils/dartdoc/dartdoc.dart#newc...
> > utils/dartdoc/dartdoc.dart:633: write(a(typeUrl(type),
> type.genericType.name));
> > I'd just use:
> >     write(a(typeUrl(type), type.genericType.name));
> > 
> > and both branches collapse to this one liner :)
> > 
> > That's the main reason that type.genericType returns "this" for non-generic
> > types. I found it leads to code that's less branchy. (though maybe we need a
> > different name than "genericType" ... something more like "baseType" or
> > "typeWithArgs" might be better ...)
> 
> Done. +1 for a better name.

lgtm

Powered by Google App Engine
This is Rietveld 408576698