Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(40)

Issue 7227006: Add inspection of function for optimized frames (Closed)

Created:
9 years, 5 months ago by Søren Thygesen Gjesse
Modified:
9 years, 5 months ago
Reviewers:
Sven Panne
CC:
v8-dev
Visibility:
Public.

Description

Add inspection of function for optimized frames R=svenpanne@chromium.org BUG=none TEST=test/mjsunit/debug-evaluate-locals-optimized.js,test/mjsunit/debug-evaluate-locals-optimized-doubles.js Committed: http://code.google.com/p/v8/source/detail?r=8556

Patch Set 1 #

Total comments: 2

Patch Set 2 : Address review comments #

Unified diffs Side-by-side diffs Delta from patch set Stats (+42 lines, -1 line) Patch
M src/deoptimizer.h View 1 2 chunks +11 lines, -0 lines 0 comments Download
M src/deoptimizer.cc View 1 2 chunks +2 lines, -0 lines 0 comments Download
M src/runtime.cc View 1 chunk +7 lines, -1 line 0 comments Download
M test/mjsunit/debug-evaluate-locals-optimized.js View 1 chunk +11 lines, -0 lines 0 comments Download
M test/mjsunit/debug-evaluate-locals-optimized-double.js View 1 chunk +11 lines, -0 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
Søren Thygesen Gjesse
9 years, 5 months ago (2011-07-06 11:53:30 UTC) #1
Sven Panne
LGTM apart from the minor typing issue, which is probably more an aesthetical remark. http://codereview.chromium.org/7227006/diff/1/src/deoptimizer.h ...
9 years, 5 months ago (2011-07-06 12:24:19 UTC) #2
Søren Thygesen Gjesse
9 years, 5 months ago (2011-07-06 13:01:43 UTC) #3
http://codereview.chromium.org/7227006/diff/1/src/deoptimizer.h
File src/deoptimizer.h (right):

http://codereview.chromium.org/7227006/diff/1/src/deoptimizer.h#newcode669
src/deoptimizer.h:669: Object* GetFunction() {
On 2011/07/06 12:24:19, Sven wrote:
> Why should we make the typing weaker here than it is? Returning JSFunction*
> seems to be more appropriate, even when we currently only need an Object*.

Good point, changed to JSFunction*.

Powered by Google App Engine
This is Rietveld 408576698